Myriad Forum « Midi Sync Problems »
 Welcome, Guest.
 You can read all messages, but to be able to post,
 please Login or Register.
Apr 11th, 2021, 4:04pm 
   Myriad Forum
   Melody Assistant / Harmony Assistant
(Moderator: Forum Administrator)
   Midi Sync Problems
« Previous topic | Next topic »
Pages: 1  Reply | Notify of replies | Print
   Author  Topic: Midi Sync Problems  (Read 2439 times)
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Midi Sync Problems  
« on: Jul 2nd, 2002, 5:26pm »
Quote | Modify

I have the following set-up...
 
Mac iBook (OS9.1) running Melody Assistant to a Midiman 2x2 midisport...
Output 1 - Multitimbral synth
Output 2 - Phrase Sampler
Input 1 - Multitimbral synth
 
The Sampler and Melody assistant are set at 121 BPM.
 
I have Melody Assistant triggering the sampler to start via midi sync which it happily does.
If I add notes to Melody Assistant via the mouse for channel 1 they stay in time with the sampler on playback.
 
If I record a part to Melody Assistant via the synth for channel 1 however, channel 1 seems to 'slow down' as the song progresses on playback.
 
Can anyone offer any ideas as to what's causing the delay? I've played around with the delay settings in the configuration but it doesn't seem to be a constant time lapse.
 
Thanks.  
 
p.s.
Please note I'm not using any internal digital sounds, it's all MIDI.
 
 
offline
Didier Guillion
Administrator
*****






   
WWW | Email

Gender: male
Posts: 8402
Re: Midi Sync Problems  
« Reply #1 on: Jul 2nd, 2002, 6:38pm »
Quote | Modify

Hi,
 
And hmmm.... Problem with OMS setup ?  
What OMS version are you using ?
 
Best regards
 
offline

Myriad Team
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #2 on: Jul 2nd, 2002, 6:58pm »
Quote | Modify

OMS 2.3.8
 
It could be OMS but I really know little about it other than I had to install it to use MIDI *
 
I've been trying a few 'test songs'... it only seems to happen when I'm recording via the synth and playing back relatively complex parts... e.g. syncaptated chord rhythms or something.
offline
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #3 on: Jul 2nd, 2002, 7:43pm »
Quote | Modify

It couldn't be some quantizing issue could it? The parts are pretty "off the wall"?
offline
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #4 on: Jul 3rd, 2002, 11:49am »
Quote | Modify

UPDATE...
I'm *pretty* sure there's a slight delay on the MIDI in for some reason... any idea why?
 
Thanks.
offline
Didier Guillion
Administrator
*****






   
WWW | Email

Gender: male
Posts: 8402
Re: Midi Sync Problems  
« Reply #5 on: Jul 3rd, 2002, 3:47pm »
Quote | Modify

Hi,
 
Very sorry, I don't understand your problem. Do you have a sample file which can illustrate it ?
 
Best regards
« Last Edit: Jul 3rd, 2002, 3:47pm by Didier Guillion » offline

Myriad Team
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #6 on: Jul 3rd, 2002, 4:09pm »
Quote | Modify

Sending you a file won't really help as the problem is only apparent when trying playing back in SYNC with the sampler.
 
Here's what's is happening... I play the synth in time with the phrase sampler and record it in Melody Assistant.
But when I play it back in Melody Assistant the synth part falls out of time with the Sampler.
 
It can't be the Sampler as any notes I have inputed via the mouse are in time.
 
... so it's as if what I play and record via MIDI IN is not recording accurately, playing back accurately or getting messed up by the quantizing.
 
Does that make sense?
offline
Esme
Board Newbie
*





   


Posts: 1
Re: Midi Sync Problems  
« Reply #7 on: Jul 3rd, 2002, 4:26pm »
Quote | Modify

Hi,
 
You could also try asking your question at:
 
http://www.macmusic.org/agora/forums/
 
They have several forums in both English and French about making music using Mac computers. One of the forums is called:
 
"Music with Macintosh on MacOS 9
Macintosh software, hardware, sequencers, plug-ins, soft synthesizers.... MacOS 7 to 9"
 
It is likely that you will find someone else with the same hardware/software setup as you who has already found a solution to the problem that you are experiencing.
 
all the best,
Esmeralda Weatherwax.
offline
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #8 on: Jul 3rd, 2002, 4:58pm »
Quote | Modify

Thanks Esme, I'll give it a go  
offline
Mikey Jetpac
Board Newbie
*






   
WWW |

Gender: male
Posts: 21
Re: Midi Sync Problems  
« Reply #9 on: Jul 3rd, 2002, 5:21pm »
Quote | Modify

Sprry I keep posting this myself but I think it's better for prosterity to have all the info posted...
 
I've been experimenting all day and I've been playing with the Midi Input delay... if I set it to +70ms or so, it works... I was beginning to think I just can't play in time
 
So for some reason my MIDI IN is slow... what I play live gets slightly delayed when it appears on the stave so it's never in time... THAT's my problem!... is that an OMS issue? Does anyone have any idea how to solve it (other than the delay setting of course).
 
offline
Mark Strange
Beta-tester
Board Junior Member
**






    g3marko
WWW | Email

Gender: male
Posts: 90
Re: Midi Sync Problems  
« Reply #10 on: Jul 4th, 2002, 12:20am »
Quote | Modify

You say that if you adjust the midi delay to +70 ms it works fine. This may be how you are to record with your hardware configuration. It is the same for those of us who record digital tracks (ie: vocals) while the melody/harmony file is playing back. We have to adjust for the time the computer takes to record our voice, even though the instrument tracks play right away.
 
Everyone's computer is different and Melody/Harmony is a type of program that will definetly work different from user to user. Please have patience while you solve you sinc problems.  
offline

Cheers,
Mark Strange
Pages: 1  Reply | Notify of replies | Print

« Previous topic | Next topic »

« Myriad Forum » Powered by YaBB 1 Gold - SP 1.1!
YaBB © 2000-2002,
Xnull. All Rights Reserved.

Top of page
Legal information Last update:  (c) Myriad